Well this new vulnerability in Open SSL/ TLS is giving headache to server administrators all over the world. If you are using Open SSL you are requested to update the SSL. If you are hosted with Abacus Desk you are safe as we are patching all our servers. If you need to know more and are little more concerned please don’t hesitate to call us.